HowTo use kamikaze b43

Aus wireless.subsignal.org
Wechseln zu:Navigation, Suche

Achtung, Technikthema!

Seit den neuesten openwrt.org-Entwicklungen (Nov'2009) laeuft nun auch der Quelloffene b43-WLAN-Treiber mit einem aktuellen Linuxkernel auf den Linksys-Geraeten (oder aehnlicher Hardware):

root@OpenWrt:/# uname -a
Linux OpenWrt 2.6.30.9 #1 Fri Nov 13 07:00:26 UTC 2009 mips GNU/Linux
root@OpenWrt:/# iw dev wlan0 station dump
Station 00:1d:73:55:d5:83 (on wlan0)
       inactive time:  280 ms
       rx bytes:       18070094
       rx packets:     65827
       tx bytes:       245584
       tx packets:     3409
       signal:         -68 dBm
       tx bitrate:     36.0 MBit/s

Garnicht zu erwaehnen brauche ich das der aktuelle OLSR-Dienst und der Rate-Auswahl-Algorithmus "minstrel" problemlos funktioniert. Folgendermassen koennt ihr das selbst nachvollziehen:

Flashen einer aktuellen trunk-Version: http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-brcm47xx-squashfs.trx

Dann aendern folgender Config Eintraege, um im weimarnetz mitzumischen:

/etc/config/wireless

config wifi-device  radio0
      	option type     mac80211
      	option macaddr	<00:AA:BB:CC:DD:EE>
        option channel  5
      	option hwmode   11ng
      	option htmode	HT40+
      	list ht_capab	SHORT-GI-40
      	list ht_capab	DSSS_CCK-40
config wifi-iface
       option device   radio0
       option mode     adhoc
       option ssid     weimarnetz
       option bssid	02:ca:ff:ee:ba:be

/etc/config/network (folgenden Eintrag hinzufuegen)

config 'interface' 'weimarnetz'
       option 'ifname'	'wlan0'
       option 'proto'	'static'
       option 'ipaddr'   '10.63.15.129'      # einstellungen fuer
       option 'netmask'  '255.0.0.0'        # knotennummer 115
       option 'dns'      '141.1.1.1'


Danach nur noch bei 'lan' die bridge auskommentieren (mit einem #) und ein 'reboot' - fertig! Mutige koennen dann noch mittels 'opkg update ; opkg install olsrd' weiterspielen.... fries43 12:41, 20. Nov. 2009 (UTC)

TEST

[12:57:52] … config wifi-device  radio0
    option type     mac80211
    option channel  5
    option macaddr    94:0c:6d:xx:xx:xx
    option hwmode    11ng
    option htmode    HT20
    list ht_capab    HT40+
    list ht_capab    HT40-
    list ht_capab    SHORT-GI-40
    list ht_capab    DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled 0

config wifi-iface
    option device   radio0
    option network  lan
    option mode     ap
    option ssid     www.evernet-eg.de
    option encryption psk2
    option key 12345

config wifi-iface
    option device radio0
    option network freifunk
    option mode adhoc
    option sw_merge 1
    option ssid sundi.freifunk.net
    option encryption 0
    option bssid 02:ca:ff:ee:ba:be
    option frag 2346